1с макет авто ширина

Ширина колонки в макете

Вывожу печатную форму, таблицу. Количество колонок может быть разным, это как пользователь галки поставит. Проблема в том, что если не выводим какие-то колонки, то остальные нужно растягивать на ширину.
Меняю ширину колонок например так:
[1с]
КолонкаЦены1 = МакетПрайса.Область(«ШапкаТаблицы|СтрокаЦена1»);
КолонкаЦены1.ШиринаКолонки = КолонкаЦены1.ШиринаКолонки*2;
[/1с]
Меняет всю колонку по отчету, и шапка документа тоже разъезжается. Смотрел примеры, вроде должно работать. Что я делаю не так?

[1с]
КолонкаЦены1 = МакетПрайса.Область(«СтрокаЦена1»);
КолонкаЦены1.СоздатьФорматСтрок();
КолонкаЦены1.ШиринаКолонки = КолонкаЦены1.ШиринаКолонки*2;

//вывод шапки таблицы
ОбластьШапкаНомер = МакетПрайса.ПолучитьОбласть(«ШапкаТаблицы|СтрокаНомер»);
ТабДок.Вывести(ОбластьШапкаНомер);
ОбластьШапкаНомен = МакетПрайса.ПолучитьОбласть(«ШапкаТаблицы|СтрокаНоменклатура»);
ТабДок.Присоединить(ОбластьШапкаНомен);
ОбластьШапкаХарак = МакетПрайса.ПолучитьОбласть(«ШапкаТаблицы|СтрокаКомментарий»);
ТабДок.Присоединить(ОбластьШапкаХарак);
//колонки цен
Если НаПечать1 Тогда
ОбластьШапкаЦена1 = МакетПрайса.ПолучитьОбласть(«ШапкаТаблицы|СтрокаЦена1»);
ЗаполнитьЗначенияСвойств(ОбластьШапкаЦена1.Параметры, СтруктураПечати);
ТабДок.Присоединить(ОбластьШапкаЦена1);
КонецЕсли;
Если НаПечать2 Тогда
ОбластьШапкаЦена2 = МакетПрайса.ПолучитьОбласть(«ШапкаТаблицы|СтрокаЦена2»);
ЗаполнитьЗначенияСвойств(ОбластьШапкаЦена2.Параметры, СтруктураПечати);
ТабДок.Присоединить(ОбластьШапкаЦена2);
КонецЕсли;
Если НаПечать3 Тогда
ОбластьШапкаЦена3 = МакетПрайса.ПолучитьОбласть(«ШапкаТаблицы|СтрокаЦена3»);
ЗаполнитьЗначенияСвойств(ОбластьШапкаЦена3.Параметры, СтруктураПечати);
ТабДок.Присоединить(ОбластьШапкаЦена3);
КонецЕсли;
Если НаПечать4 Тогда
ОбластьШапкаЦена4 = МакетПрайса.ПолучитьОбласть(«ШапкаТаблицы|СтрокаЦена4»);
ЗаполнитьЗначенияСвойств(ОбластьШапкаЦена4.Параметры, СтруктураПечати);
ТабДок.Присоединить(ОбластьШапкаЦена4);
КонецЕсли;
Если НаПечать5 Тогда
ОбластьШапкаЦена5 = МакетПрайса.ПолучитьОбласть(«ШапкаТаблицы|СтрокаЦена5»);
ЗаполнитьЗначенияСвойств(ОбластьШапкаЦена5.Параметры, СтруктураПечати);
ТабДок.Присоединить(ОбластьШапкаЦена5);
КонецЕсли;
[/1с]

(11) Вот я вывел шапку документа. Потом сделал СоздатьФормаСтрок(). Потом вывожу шапку таблицы, которая должна быть по моим новым размерам. Выводится чистая строка, и шириной колонок поумолчанию. Ничего не заполняет. ((

Попутно ищу как сделать вертикальную область, которая будет распространятся только на определенные строки. В других макетах вижу, не пойму как сделано. Встаю на одну горизонтальную область, появляются вертикальные области. Перехожу на другую горизонтальную область, вертикальные области пропадают.

Источник

Читайте также:  Термометр в автомобиль обзор
Поделиться с друзьями
Расскажем обо всем понемногу